System Status

Power outage

Incident Report for System Status

Critical Impact
Resolved

All services have been restored following the power outage in our Zone 1

Aug 4, 2026, 09:40 AM UTC
Identified

We're restarting services

Aug 4, 2026, 08:37 AM UTC
Identified

We're restarting services

Aug 4, 2026, 08:35 AM UTC
Power outage - Piloterr Status Page